Page 1 of 1

HTML - PLA wird nicht beendet

Posted: 19 Dec 2018, 10:23
by xBSCx
Hallo zusammen,

im HTML-Client gibt es leider immer noch den Bug, dass PLA virtuell "hängen bleiben". Der Screenshot zeigt eine PLA, die seit ca. 1h angeblich nicht beendet wurde, obwohl die Transen die Route fahren.
Erst nach Relog ist der Auftrag erledigt und man kann den nächsten starten. Es tritt unregelmäßig auf, daher kann man sich nicht einmal darauf einstellen.

Ich glaube, das war einer der Gründe, warum ich den HTML-Client nicht weiter getestet hatte.

Gruß
BSC

Re: HTML - PLA wird nicht beendet

Posted: 19 Dec 2018, 11:09
by Radical
Hallo xBSCx,

danke für die Meldung. Ich habe das mal in unsere Bugliste aufgenommen.
Es ist leider nicht so einfach das zu reproduzieren.
Falls du uns helfen möchtest, wäre es prima, wenn du mal die Entwicklerkonsole in deinem Browser offen halten würdest.
Wenn ein Fehler auftritt, kann es gut sein dass dieser in der Konsole dann auch angezeigt wird.
Die Entwicklerkonsole geht je Browser anders auf, bei Chrom zum Beispiel so:
Bildschirmfoto 2018-12-19 um 11.07.53.jpg


Wenn du dort Fehler siehst, gerne an uns melden.

Danke & Gruß

Jakob

Re: HTML - PLA wird nicht beendet

Posted: 19 Dec 2018, 11:40
by xBSCx
ich hab es verfolgt, es gab leider nicht eine Fehlermeldung in der Konsole :-(
Zwischendurch mal ein TimeOut, der aber nicht zu einem Fehler geführt hat.

Re: HTML - PLA wird nicht beendet

Posted: 19 Dec 2018, 11:57
by xBSCx
ein reporteter Fehler aus der Konsole, hat aber nichts mit der Anzeige zu tun. Sieht eher so aus, als solle er von der C:-Platte was laden, was er aber nicht finden kann ;-)

BaseLoader.hx:128: Error loading file "C:/gamefabrik/mars/mainline/client/assets/mesh/mod/mod_container_bigbox.3do": There is no asset library named "C"

Re: HTML - PLA wird nicht beendet

Posted: 19 Dec 2018, 12:36
by xBSCx
Folgenden Fehler kriege ich häufiger, diesmal lief auch die PLA nicht weiter.

6 mars.js:1321 NetRequest.hx:232: onTimeOut timeOut:15000

Re: HTML - PLA wird nicht beendet

Posted: 21 Dec 2018, 08:05
by xBSCx
Hi ihr beiden,

ich kann verstehen, dass der Bug schwer nachvollziehbar ist. Aber es raubt einem den Spielspass, wenn man für eine PLA mit 20t 2x neuladen muss, um zu sehen, ob sie fertig ist. Die eingesetzte Transe hat 14t, musste also 2x reinkommen. Nach dem 2. Relog hatte ich 56t in den Ziel-AP geliefert :-(

Gruß
BSC

Re: HTML - PLA wird nicht beendet

Posted: 21 Dec 2018, 09:00
by Radical
Hi xBSCx,

wir hatten in 1.26.6 einen Ansatz. Anscheinend hat der aber nicht gegriffen.
Ich habe den bug mal hoch priorisiert. Wir sind dran.

Gruß

Rad

Re: HTML - PLA wird nicht beendet

Posted: 21 Dec 2018, 10:22
by xBSCx
ich probiere es jetzt mal mit Firefox, mal sehen, ob da mehr geloggt wird und ob es da dieselben Probleme gibt

Re: HTML - PLA wird nicht beendet

Posted: 21 Dec 2018, 11:58
by xBSCx
FF macht leider die gleichen Probleme.

Vielleicht hilft euch davon irgendwas.

NetRequest.hx:240: Retry call mHttpRequest:https://de1.mars-tomorrow.com/api/guild/infos mIOCount:0 mDisposed:false timeOut:5000
mars.js:1321:395
NetRequest.hx:232: onTimeOut timeOut:5000
mars.js:1321:395
NetRequest.hx:240: Retry call mHttpRequest:https://de1.mars-tomorrow.com/api/transporter/navigation mIOCount:0 mDisposed:false timeOut:5000
mars.js:1321:395
NetRequest.hx:232: onTimeOut timeOut:5000
mars.js:1321:395
NetRequest.hx:240: Retry call mHttpRequest:https://de1.mars-tomorrow.com/api/transporter/navigation mIOCount:0 mDisposed:false timeOut:5000

Gruß
Bernd

Re: HTML - PLA wird nicht beendet

Posted: 16 Jan 2019, 12:42
by Radical
Wir haben da einen neuen Ansatz, der auch das Chatproblem beheben könnte.
Mit dem nächsten Update wissen wir mehr.